Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2024 - 13:00 UTC
Scheduled
Start: 27/08/2024, 13:00 UTC End: 27/08/2024, 15:00 UTC --- During this time period, our Engineering team will be performing maintenance on one of our VPS clusters in Hosting Control Panel. Short-term service unavailability is expected during this maintenance.
We apologize for any inconvenience it may cause.
Posted Aug 13, 2024 - 13:33 UTC
This scheduled maintenance affected: Hosting (Minneapolis (MIN4)).