Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 29, 2024 - 03:00 UTC
Scheduled
Start: 29/10/24, 03:00 UTC End: 29/10/24, 22:00 UTC --- During this time period, our engineering team will perform maintenance that may result in short-term degraded performance for up to 480 minutes.
We sincerely apologize for any inconvenience it may cause.
Posted Oct 28, 2024 - 13:12 UTC
This scheduled maintenance affected: Hosting (Minneapolis (MIN4)).