Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 02, 2024 - 08:00 UTC
Scheduled
Start: 02/05/2024, 08:00 UTC End: 03/05/2024, 05:00 UTC --- During this time period, our Engineering team will be performing maintenance. Short-term packet loss may be expected during it. We apologize for any inconvenience it may cause.
Posted Apr 11, 2024 - 08:50 UTC
This scheduled maintenance affected: Hosting (Santiago de Querétaro (SQR)).