Streaming | Live streaming in ED1 region incident details
Incident Report for Gcore
Resolved
We'd like to inform you that the issue has been resolved.

– On June 20, 2024, at 02:00 UTC, a live-segmenter crashed, causing HTTP/503 errors that obstructed a transcoding application from updating its output. Though ingest and transcode operations continued to function correctly.
– The monitoring system automatically restarted the live-segmenter; however, it caused a deadlock issue that was reported by monitoring without flagging it as a problem.
– The issue was detected by engineers at 06:41 UTC, and the live-segmenter functionality was fully restored by 06:56 UTC.
– The root cause was identified as a deadlock in the latest version of the live-segmenter, which has since been corrected in the code. Monitoring adjustments have been implemented to accurately track such issues in the future.

We apologize for any inconvenience this may have caused you, and want to thank you for your patience and understanding throughout this process.
Posted Jun 26, 2024 - 08:31 UTC
Monitoring
We are pleased to inform you that our engineering team has implemented a fix to resolve transcoding outage in ED1 region.

The functionality of transcoding of all streams has been fully restored. We continue to monitor the situation.

We will provide you with an update as soon as we have confirmed that the issue has been completely resolved.
Posted Jun 20, 2024 - 07:33 UTC
Investigating
One of our service of transcoding of live streams in ED1 region experienced an outage. As a result, some live streams are currently unavailable.

Our technical team is actively working to resolve the issue and restore full functionality as quickly as possible.

We will provide you with an update as soon as we have more information on the progress of the resolution. Thank you for your understanding and cooperation.
Posted Jun 20, 2024 - 06:44 UTC
This incident affected: Streaming (Streaming).