Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 31, 2023 - 20:00 UTC
Scheduled
Start: 31/10/23, 20:00 UTC End: 31/10/23, 23:00 UTC --- During this time period, our Engineering team will be performing maintenance. Short-term network degradation and increased RTT up to 30m. We apologize for any inconvenience it may cause.
Posted Oct 20, 2023 - 01:48 UTC
This scheduled maintenance affected: Hosting (Hong Kong (GNC)).