CDN | Cairo, Egypt incident details
Incident Report for Gcore
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 08:14 UTC
Investigating
We are currently experiencing performance issues. During this time, users may experience slow or unusual functioning of the service.

We apologize for any inconvenience this may have caused and will share an update once we have more information.
Posted Mar 08, 2023 - 22:14 UTC
This incident affected: CDN (Cairo, Egypt).